Cloudflare believes they've resolved the issue and that all services have been restored. We'll continue to monitor.
Posted Nov 18, 2025 - 07:48 MST
Identified
Several of Clearfly's services are protected by Cloudflare WAF services, which are currently down. This is resulting in intermittent reachability from some regions to Clearfly's Portal.
Posted Nov 18, 2025 - 07:22 MST
This incident affected: Messaging (Message Delivery) and Clearfly Portal, cFax.